Security Upgrade for Internet Banking

17Oct2014

People’s Choice would like to advise members that in order to reduce any risk associated with the recently identified “POODLE” bug, we will be making a security upgrade to our services as of today, Friday 17 October.

As a result, all members using a combination of Windows XP operating system and Internet Explorer 6 will have issues logging into Internet Banking.

In order for impacted members to continue to access Internet Banking we’re asking that they upgrade their internet browser.

Please note: Microsoft do not support Internet Explorer 9 on Windows XP so please install one of the other options such as Google Chrome or Mozilla Firefox.

To confirm the version of Internet Explorer being used, navigate to ‘About Internet Explorer’ on the Help tab of the Toolbar.

Please use our Upgrade your Browser page to help you download the latest browser version.

For any questions please contact our National Contact Centre on 13 11 82. 

Filed under: News

Copyright © 2017 People's Choice Credit Union, a trading name of Australian Central Credit Union Ltd
ABN 11 087 651 125    Australian Financial Services Licence (244310) and Australian Credit Licence (244310)    BSB 805-050